Tuesday, April 6, 2010

No Dice

It is 8 p.m.

I'm so frustrated, I can't even speak.

Unfortunately for me, the returned pump, which came late last week didn't solve the problem. It now pumps, but I can't get the proper vacuum level (which is 29.5 inches), I can only get 25-6. Which doesn't seem to be enough to make the investment boil. I'm going to have to try to invest and cast a few things (that are very late!) and see how that goes :-(. I'm not sure what will happen. At best I think there will be small air bubbles on the cast pieces which can then be removed physically. Nothing is really lacy or intricate, so that helps. At worst the molds will be weak and molten metal will burst through (!!!). I bought this machine brand new in October, so I'm pretty irritated that I'm having these issues with it already. The Shop Monkey is taking point on this and has been talking to Pepetools and Otto Frei. I'm hoping they will just send me a new machine. Anyhow, here are pictures of the molds I just invested, cross your fingers for me tomorrow, I'm hoping everything just turns out okay. As always, I'm not sure what I would do without my trusty Shop Monkey.



STUPID MACHINE.

3 comments:

ashleyskala said...

What a pain! I hope they replace it for you, considering it's so new and it definitely seems like a defective machine.

I'm frustrated too, but for a different reason. I just overheated the piece I was working on. That's what I get for not taking my time!

v佳馥虹玲 said...

cool blog,期待更新........................................

kimberly said...

My fingers are crossed that the casts turn out well...I have faith!

Your blog continues to be an inspiration into my goal of becoming a jewelry designer and maker- thanks for sharing both the ups and downs!

p.s. I already read you in Google Reader, but visited today to comment...thus, I'm not sure how long your header has been around, but I LOVE it!